[PATCH] filter: refactor cgit_new_filter()

John Keeping john at keeping.me.uk
Tue Jan 14 22:59:40 CET 2014

On Tue, Jan 14, 2014 at 09:54:21PM +0100, Jason A. Donenfeld wrote:
> On Tue, Jan 14, 2014 at 9:39 PM, John Keeping <john at keeping.me.uk> wrote:
> > I like the simplification, but I'm not sure the result is better.  Even
> > without the rest we should replace the strncmp with prefixcmp though.
> Agreed.
> >
> > There's actually no reason we couldn't mutate "cmd" here, which would
> > simplify it a lot, but I'm not sure we want to remove the const
> > modifiers all the way through.  Then we can just do "*colon = '\0'" and
> > use strcmp.
> IMHO, it's better to keep lookup tables like these in the read-only
> section. Let's keep the constness.

I meant for the input, which is read from the config file.  Just
terminate the user-specified command string at the colon and treat it as
two genuinely separate strings.

More information about the CGit mailing list