[PATCH v2 1/1] git: preview for v2.3.0-rc0
Christian Hesse
list at eworm.de
Fri Jan 16 09:33:31 CET 2015
John Keeping <john at keeping.me.uk> on Thu, 2015/01/15 22:01:
> On Wed, Jan 14, 2015 at 04:34:20PM +0100, list at eworm.de wrote:
> > From: Christian Hesse <mail at eworm.de>
> >
> > * sort_string_list(): rename to string_list_sort() (upstream commit
> > * 3383e199)
> > * update read_tree_recursive callback to pass strbuf as base (upstream
> > commit 6a0b0b6d)
> >
> > Signed-off-by: Christian Hesse <mail at eworm.de>
> > ---
> > Makefile | 4 ++--
> > cgit.c | 2 +-
> > git | 2 +-
> > ui-blob.c | 15 ++++++++-------
> > ui-plain.c | 16 ++++++++--------
> > ui-tree.c | 23 +++++++++++------------
> > 6 files changed, 31 insertions(+), 31 deletions(-)
> >
> > diff --git a/Makefile b/Makefile
> > index 38bf595..36c30a8 100644
> > --- a/Makefile
> > +++ b/Makefile
> > @@ -14,8 +14,8 @@ htmldir = $(docdir)
> > pdfdir = $(docdir)
> > mandir = $(prefix)/share/man
> > SHA1_HEADER = <openssl/sha.h>
> > -GIT_VER = 2.2.1
> > -GIT_URL =
> > https://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.gz
> > +GIT_VER = 2.3.0.rc0 +GIT_URL =
> > https://www.kernel.org/pub/software/scm/git/testing/git-$(GIT_VER).tar.gz
> > INSTALL = install COPYTREE = cp -r
> > MAN5_TXT = $(wildcard *.5.txt)
> > diff --git a/cgit.c b/cgit.c
> > index 79019c2..df301ea 100644
> > --- a/cgit.c
> > +++ b/cgit.c
> > @@ -599,7 +599,7 @@ static int prepare_repo_cmd(void)
> > free(tmp);
> > return 1;
> > }
> > - sort_string_list(&ctx.repo->submodules);
> > + string_list_sort(&ctx.repo->submodules);
> > cgit_prepare_repo_env(ctx.repo);
> > choose_readme(ctx.repo);
> > return 0;
> > diff --git a/git b/git
> > index 9b7cbb3..addfb21 160000
> > --- a/git
> > +++ b/git
> > @@ -1 +1 @@
> > -Subproject commit 9b7cbb315923e61bb0c4297c701089f30e116750
> > +Subproject commit addfb21a94fb4e6b9d07b270f7bb3748767a8f38
> > diff --git a/ui-blob.c b/ui-blob.c
> > index c2de8d6..4e29223 100644
> > --- a/ui-blob.c
> > +++ b/ui-blob.c
> > @@ -18,15 +18,16 @@ struct walk_tree_context {
> > int file_only:1;
> > };
> >
> > -static int walk_tree(const unsigned char *sha1, const char *base, int
> > baselen,
> > - const char *pathname, unsigned mode, int stage, void *cbdata)
> > +static int walk_tree_buf(const unsigned char *sha1, struct strbuf *base,
> > + const char *pathname, unsigned mode, int stage,
> > + void *cbdata)
>
> This seems unnecessarily noisy. The patch would be easier to read if
> the function name stays the same and you avoid re-wrapping the
> parameters. It would also remove several of the hunks below because the
> call sites won't need to change.
Already changed that in my local repository. ;)
--
main(a){char*c=/* Schoene Gruesse */"B?IJj;MEH"
"CX:;",b;for(a/* Chris get my mail address: */=0;b=c[a++];)
putchar(b-1/(/* gcc -o sig sig.c && ./sig */b/42*2-3)*42);}
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://lists.zx2c4.com/pipermail/cgit/attachments/20150116/62c92d9f/attachment.asc>
More information about the CGit
mailing list