Missing branches

Dunnigan, Terrence J terrence.j.dunnigan at boeing.com
Thu Sep 24 23:52:52 CEST 2015

On Wed, Sep 23, 2015 at 01:26:14AM +0000, Dunnigan, Terrence J wrote:
>> The missing branches neither appear on the summary page nor the refs 
>> page, even after cleaning the browser cache.
>> When I run 'git for-each-ref' in the git repository on the git server 
>> I see all of the branches.

>Were you running as the same user as CGit?  Is there any chance that filesystem permissions are inconsistent?

>> It's as if cgit is looking at an older version of the repo, even 
>> though the scan path points to the same directory in which I just 
>> performed 'git for-each-ref'.

>Have you tried adding the repository explicitly?  You can set repo.url to something unrelated so that the explicit version does not interfere with the one discovered by "scan->path".

It appears to have been a file permission issue. As soon as we started changing file and directory permissions we started seeing the missing branches.

Thanks for the troubleshooting advice!


> -----Original Message-----
> From: John Keeping
> Sent: Tuesday, September 22, 2015 5:42 PM
> To: Dunnigan, Terrence J
> Cc: cgit at lists.zx2c4.com
> Subject: Re: Missing branches
> On Tue, Sep 22, 2015 at 09:25:19PM +0000, Dunnigan, Terrence J wrote:
> > One of our cgit instances (0.10.1) is not displaying all branches in 
> > a repo. We've turned caching off (cache-size = 0) and deleted the 
> > cache under /var/cache/cgit, and we are still missing branches.
> > 
> > The branches are missing from multiple repos. We've verified that 
> > scan-path points to the correct directory, and that the git 
> > repository directory actually has the missing branches.
> > 
> > For some reason, cgit is just not displaying all of the branches. 
> > One repo has 5 branches yet cgit only displays 2, for example.
> Do you mean on the summary page or the refs page?  The refs page 
> should show everything but the summary page will only show the number 
> allowed by the "summary-tags" and "summary-branches" configuration 
> variables, although those default to 10.
> Can you run `git for-each-ref` in the repository CGit is displaying to 
> see if the branches show up there?  CGit should be displaying 
> everything under "refs/heads/".

More information about the CGit mailing list