[PATCH 1/1] RFC: git: update to v2.18.0-rc2

Jason A. Donenfeld Jason at zx2c4.com
Sat Jun 16 18:15:17 CEST 2018

On Sat, Jun 16, 2018 at 6:14 PM John Keeping <john at keeping.me.uk> wrote:
> But we still have a few mentions of sha1 in our code.  Most of this is
> sha1 and sha2 in struct cgit_query, but these aren't actually hashes
> most of the time, they can be any object reference that Git understands,
> so I think we should rename them to ref1 and ref2 (along with has_sha1
> -> has_ref).  What do you think?

Yes, please. This is some excellent progress.

More information about the CGit mailing list