[pass] Pass on Maemo

Adam Wellings skanky at kapin.co.uk
Fri Apr 18 20:41:16 CEST 2014

On Fri, 18 Apr 2014, Matthieu Weber wrote:

>On Thu 17.04.2014 at 11:05:02PM +0100, Adam Wellings wrote:
>> I'm just wondering if anyone has used pass on Maemo (Nokia n900) or similar?
>I am using pass on a n900 (although not very often).

Thanks - at least I have a target. :)

>> I've installed it and hit a couple of issues and I've initially worked
>> round a couple of them, but before I get too far down the line, I just
>> wondered if there's a better way.
>> 1) Pass calls gpg2, whereas gpg on Maemo is gpg. Initially I edited
>> the script to change the calls to gpg - but when I resolve the other
>> issues, I'll reinstall pass and instead set-up a link to from gpg2 to
>> gpg.
>I hacked pass to change gpg2 to gpg and remove the --batch option. Since
>then, pass 1.5 came out and detects if you have gpg2 or only gpg.

I hadn't tried removing the --batch option. Which I had.

>> 2) mkdir in busybox doesn't support the -v option. I've manually
>> removed this option from the script. Again, I may instead set-up a
>> different resolution. I'll probably wrap mkdir with a a function that
>> "eats" the option.
>Good point, I didn't even remember doing that too. But since -v is not
>essential, I don't really care :)

The only issue is I think -v is not always first. Doesn't make eating it
impossible, just harder. If/when I get it sorted, I'll post the function here.
It might be a few days though.

>> 3) Pass now encrypts no problem, but when it decrypts it calls gpg,
>> which calls gpg-agent but that returns an error that it can't
>> execute pinentry. That error
>> message is very generic but *suggests* it can't find pinentry.
>> "can't connect to the PIN entry module: End of file"
>> I can run pinentry manually.
>> I realise this isn't gpg list and I'll ask on there if I can't resolve it but I
>> wondered if anyone else had seen this.
>Removing the --batch option and using gpg instead of gpg2 removes the
>need for pinentry. Since there is no gpg-agent in maemo, I have gpg
>asking me straight on the terminal for my passphrase, everytime it is

I found gpg-agent and pinentry in one of the repos - might have been a dev one,
I didn't look to see where they were. The pinentry works when run manually, but
gpg-agent is having trouble callling it. I might just ditch it though,
especially if 1.5 removes the need for --batch.

>> Also, if I don't use gpg-agent (and after the above error) I get an error
>> message from gpg saying it can't ask for the passphrase in batch mode. I'm
>> tempted to remove the batch option from pass on the phone.
>As Jason mentioned in his answer, pass 1.5 solves the gpg2/gpg problem,
>the need for pinentry and the absence of gpg-agent. The only thing that
>remains to be hacked in maemo is the mkdir -v option.

Great. Hopefully in the next day or few I'll get 1.5 installed, remove gpg-agent
and write the function to eat the -v option. I'll post back here when I get some
progress (very busy with real life at the moment, but should get time on Tuesday
if not before).

Many thanks for the answers, all.


More information about the Password-Store mailing list