[pass] Error if older version of tree is installed
mail at lenzw.de
Fri Jun 26 17:33:51 CEST 2015
Okay, I checked this one.
>From pass version 1.6.0 on, pass depended on tree 1.7. The features it depends on came... from the pass community ;)
Also see http://git.zx2c4.com/password-store/tag/?h=1.6 on this.
So far, so good:
Ubuntu `trusty` ships with pass 1.4.2-3 and tree 1.6 - which should be compatible
Newer versions of Ubuntu shipping with pass >=1.6 also include tree 1.7
So this is a classic case of "if you are installing software that is newer than your distribution, you may run into some minor problems".
Unfortunately, this cannot be avoided as it would result in absolute statgnation :/
What could be nice though would be a check in the Makefile if tree>=1.7 is present and a (non-blocking) warning, if that is not the case.
In that context: patches are always welcome (though it may take a while until they are added) ;)
Am 26.06.2015 um 12:38 schrieb Mathias Renner:
> Hello everyone,
> I joined this list since this seems to be the place to get in touch with
> the community (I was looking for a bug report system - did not find any).
> I suggest to include in the docs or setup pages, that to be able to run
> `pass find` you need to have tree version 1.7.0 installed. Otherwise,
> this command outputs an error. Tree version 1.7.0 is at least not in
> the repos for Fedora 20 and Ubuntu 14.04 LTS yet.
> I had to download tree directly from the developers' website and compile
> it manually: http://mama.indstate.edu/users/ice/tree/
> Otherwise, I love pass, thank you guys for developing and maintaining it!!
> Password-Store mailing list
> Password-Store at lists.zx2c4.com
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Password-Store