Installing and 'quick starting' on CentOS 7

Craig Marker cmarker at
Thu Apr 20 20:23:07 CEST 2017

Hey all!

I’ve been following WireGuard for sometime and was excited to see that it now runs on the 3.10 kernel! I tried getting it running this morning, and have run into a handful of problem. I’m wondering if anyone else has run into or is running into similar problems.

Following the installation instructions, option A fails, though this appears to be a known issue:

cmarker at hw2 src]$ sudo dnf copr enable jdoss/wireguard
No such command: copr. Please use /bin/dnf --help
It could be a DNF plugin command.

I tried poking around on my computer and online and didn’t find anything that helped make option A work.

The next thing I tried was snagging the rpms from online and installing them directly. I found them here:, but using dnf to install wireguard-tools and wireguard-dkms left me without a proper installation (namely lsmod | grep wireguard returned nothing).

I then tried to compiling from source. gcc version: gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-11). I have libmnl(-devel) installed as well: libmnl-1.0.3-7.el7.x86_64, libmnl-devel-1.0.3-7.el7.x86_64. I ran the dnf install command: sudo dnf install libmnl-devel kernel-devel @development-tools pkg-config, which didn’t install anything new for me — in fact, it said “No package pkg-config available.”

I grabbed the code, untar’d it, and cd’d to source and ran make. It returned a whole host of errors. If those are interesting, I can c/p; it was multiple screens full.

Of note, I am running on 3.10.0-514.16.1.el7.x86_64 kernel, which is the most recent CentOS 7 kernel released. In terms of the necessary kernel configuration options, some of them were statically loaded, others weren’t. The ones that weren’t I attempted to remedy by loading the associated kernel module. Let me know if that is not the supported way to approach this.

	• CONFIG_NET_UDP_TUNNEL=m (loaded via modprobe udp_tunnel)
	• CONFIG_NF_CONNTRACK=m (loaded via modprobe nf_conntrack)
	• CONFIG_NETFILTER_XT_MATCH_HASHLIMIT=m (loaded via modprobe xt_hashlimit)
	• CONFIG_IP6_NF_IPTABLES=m (loaded via modprobe ip6_tables)

Let me know if more information is needed. Any advice is appreciated!


More information about the WireGuard mailing list