trouble installing on Fedora and CentOS

Joe Doss joe at
Wed Aug 9 16:54:06 CEST 2017

On 08/09/2017 07:39 AM, adam souzis wrote:
> Hi Joe,
> Thanks for looking into this, yes you are correct that my machine's 
> kernel version didn't match with what the rpm expected, I discovered 
> this when I tried to build from source. Maybe this error should be fatal 
> or output a message suggesting the expected kernel?

I am not sure how must effort that will require. If anyone has any ideas 
on how to make this edge case better I am all ears.

For the time being, just ensure you have the right kernel-headers 
installed for your running kernel and you should be fine.

> Have you tried to get your packages to working on an Atomic Host build? 
> When I did, the install failed:
> [fedora at atomic~]$ uname -r
> 4.11.11-300.fc26.x86_64
> [fedora at atomic~]$ sudo rpm-ostree install 
> ./wireguard-dkms-0.0.20170726-1.fc26.noarch.rpm
> Checking out tree 0715ce8... done
> Resolving dependencies... done
> Overlaying... done
> *error: *Running %post for wireguard-dkms: Executing 
> bwrap(/usr/ Child process exited with code 8
> So I just copied the wireguard.ko and wg binaries over from a regular 
> Fedora 26, did an insmod and things are working, so I'm good for now.

If I get some time I will ask the folks in #atomic what the best method 
is for adjusting a F26 RPM to work in Atomic. My hunch it is failing 
when it tries to write the WireGuard files to /usr/src/ which is read 
only (I think).


Joe Doss
joe at

More information about the WireGuard mailing list