Bug report: WG won't reinstall after some OS recover procedures

Jonathon Fernyhough jonathon.fernyhough at york.ac.uk
Mon Dec 18 15:43:10 CET 2017

On 18/12/17 14:29, Nicholas Joll wrote:
> To Whom It May Concern
> What happened. (1) On a system on which Wireguard was working, I used
> the 'TimeShift' program to restore Linux Mint from backup - twice, on
> one occasion including within the restore a reinstall of Grub and
> rebuild of initramfs. (Points 2-3 that follow apply to both versions of
> the restore.) (2) After the restore, WG still worked. (3) I updated the
> kernel (on one occasion before rebooting, or another after rebooting).
> (4) WG no longer worked. When I tried to reinstall it, it gave
> 'post-install' messages about how the dkms module was installed already.
> All manner of package removal and purging and file deletion failed to
> achieve anything - until I discovered that deleting a file in
> /var/lib/dkms/wireguard/ (together with 'sudo dkms --reconfigure -a'?)
> fixed things.
> What should have happened. WG should be able to cope with such a
> restore. At worst, it should give the user messages about how to fix the
> problem.
> System Concerned: Linux Mint 18.3 Cinnamon; WG 0.0.20171211.

This sounds like an issue centred on DKMS rather than WireGuard itself.

Do you have any other DKMS-managed kernel modules? If so, how did they
cope with the restore process?

Which WireGuard packages are you using?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.zx2c4.com/pipermail/wireguard/attachments/20171218/76731e99/attachment.asc>

More information about the WireGuard mailing list