(Unofficial) wireguard packages for Debian Stretch (testing)

Baptiste Jonglez baptiste at bitsofnetworks.org
Wed Feb 15 22:31:54 CET 2017

On Tue, Feb 14, 2017 at 10:50:14AM -0500, Daniel Kahn Gillmor wrote:
> on a similar system i'm using (stretch, with unstable available but
> pinned low), i see only packages from stretch being installed (aside
> from wireguard itself, clearly)
> 0 root at test:~# cat /etc/apt/sources.list.d/unstable.list 
> deb http://ftp.us.debian.org/debian/ unstable main
> 0 root at test:~# cat /etc/apt/preferences.d/limit-unstable 
> Package: *
> Pin: release a=unstable
> Pin-Priority: 200

Thanks for the hint, it worked fine on my stretch system!  Here are the
packages that got pulled:

The following NEW packages will be installed:
  dkms linux-compiler-gcc-6-x86 linux-headers-4.9.0-1-amd64
  linux-headers-4.9.0-1-common linux-headers-amd64 linux-kbuild-4.9
  wireguard-dkms wireguard-tools

On jessie, it worked exactly the same with the 4.9 kernel from

# cat /etc/apt/sources.list
deb http://httpredir.debian.org/debian jessie main
deb http://httpredir.debian.org/debian jessie-backports main
deb http://httpredir.debian.org/debian unstable main
# cat /etc/apt/preferences.d/limit-unstable
Package: *
Pin: release a=unstable
Pin-Priority: 200
# apt update
# apt install -t jessie-backports linux-image-amd64 linux-base
# reboot
# apt install wireguard-dkms wireguard-tools
# ./client.sh
# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=15.1 ms

For the record, it also works fine with the 4.1.34.mptcp kernel from
multipath-tcp.org on jessie :)

Jason, can you write something up on the Wireguard website, since it's so

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.zx2c4.com/pipermail/wireguard/attachments/20170215/c114dcc7/attachment.asc>

More information about the WireGuard mailing list