link disappears

ST smntov at
Thu Mar 22 19:26:48 CET 2018


I'm new to networking in general and VPN in particular but need to setup
infrastructure to be able to SSH easily to several people who are behind
routers (NAT). After reading that WireGuard is super simple - I decided
to give it try.

It indeed turned out to be simple till now. I setup a Debian virtual
server with a public IP and configure it as follows:


# wg
interface: wg0
  public key: QMwhCacViCKcTrkevg5NxLnTEJDU1bTNgQp43rp7BHM=
  private key: (hidden)
  listening port: 12000

peer: hiUdjmCK+iZf8wGEB+rYxMYYBF8QoOsm3nkF3asllRY=
  endpoint: 37.X.Y.Z:4488
  allowed ips:
  latest handshake: 17 minutes, 50 seconds ago
  transfer: 30.94 KiB received, 22.03 KiB sent

Node behind NAT:
# wg
interface: wg0
  public key: hiUdjmCK+iZf8wGEB+rYxMYYBF8QoOsm3nkF3asllRY=
  private key: (hidden)
  listening port: 12000

peer: QMwhCacViCKcTrkevg5NxLnTEJDU1bTNgQp43rp7BHM=
  endpoint: 195.A.B.C:12000
  allowed ips:
  latest handshake: 19 minutes, 11 seconds ago
  transfer: 20.70 KiB received, 35.57 KiB sent
  persistent keepalive: every 25 seconds

Is everything OK here?... At the beginning everything worked as expected
- I could ping/SSH in both directions via the private and addresses. Later I put my desktop into "hibernate mode" and
after turning it on again could no longer use the link...

I tried to "ip link set wg0 down" and then "... up" - handshake time
gets reseted, but I do not get the link back, "ip a" shows:

6: wg0: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1420 qdisc noqueue state
UNKNOWN group default 

How can I revive this link, once the wg0 interface is already

(I have docker and virtualbox running on the desktop, each have its
network interface... could they interfere with wg0?)

Thank you in advance!

More information about the WireGuard mailing list