Trouble with WG on Synology NAS

Berend D. cyberwizzard at
Sat Jul 6 13:15:46 CEST 2019

I am using WireGuard on my Synology 415+ NAS which runs Linux kernel

I tried a couple versions of wireguard now, using as inspiration to compile
them, but none of them seem to work.

The problem I experience is that everything is seemingly correctly set up
(I have a Linux server elsewhere to compare configs with) but after
connecting to Wireguard, the server only seems to be able to receive
packets, not send them: when pinging the NAS I can see the ifconfig RX
packet counter go up, and at the same time the TX error counter as well.

wg0       Link encap:UNSPEC  HWaddr
          inet addr:  P-t-P:  Mask:
          UP POINTOPOINT RUNNING NOARP  MTU:1420  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:21 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:564 (564.0 B)  TX bytes:124 (124.0 B)

I ran over my config multiple times now but I can not spot a difference to
my working setup on the other server. I also tried various clients
(Android, Ubuntu, Windows 10 both the WG client and an alternative

Tested versions:
- 0.0.20190227-2
- 0.0.20190601
- 0.0.20190 <>702

The only thing the Synology build changes is to force memneq on since its
not supported (the 'ifeq' in Kbuild.include is removed via patch so its
always included).

I can not find a way to make it all more verbose to figure out why the
packets are dropped by WG.

What can I try to debug this?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the WireGuard mailing list