MacOS IPv6 not functioning without custom static route

Hasan Berkay Çağır berkay at
Tue Jul 21 15:12:48 CEST 2020

On 15/07/2020 14:14, Adam Cooper wrote:
> ...
> Probably worth mentioning that I tried to replace ::/0 with ::/1,
> 8000::/1 but that just results in completely broken connectivity in
> IPv6 and IPv4 - which may be another issue in and of itself.

Did you try only having "::/1, 8000::/1" in the AllowedIPs option? I had 
a default route creation issue myself where I'm only trying to tunnel 
IPv6 through; and having this actually solved it.

$ netstat -nr
Routing tables
Destination                             Gateway                         
Flags         Netif Expire
::/1                                    link#14                         
UCS           utun2
default                                 fe80::%utun0                    
UGcI          utun0
default                                 fe80::%utun1                    
UGcI          utun1
default                                 fe80::%utun3                    
UGcI          utun3
default                                 [ public IPv6 ]                 
UGcI          utun2

If just "::/1, 8000::/1" solves the IPv6 issue, I guess you can give it 
a try with ", ::/1, 8000::/1" to see if both routes are created 


More information about the WireGuard mailing list