[PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()
longman at redhat.com
Tue Jun 16 21:43:16 CEST 2020
On 6/16/20 2:53 PM, Joe Perches wrote:
> On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote:
>> - Break out the memzero_explicit() change as suggested by Dan Carpenter
>> so that it can be backported to stable.
>> - Drop the "crypto: Remove unnecessary memzero_explicit()" patch for
>> now as there can be a bit more discussion on what is best. It will be
>> introduced as a separate patch later on after this one is merged.
> To this larger audience and last week without reply:
> Are there _any_ fastpath uses of kfree or vfree?
I am not sure about that, but both of them can be slow.
> Many patches have been posted recently to fix mispairings
> of specific types of alloc and free functions.
> To eliminate these mispairings at a runtime cost of four
> comparisons, should the kfree/vfree/kvfree/kfree_const
> functions be consolidated into a single kfree?
> Something like the below:
> void kfree(const void *addr)
> if (is_kernel_rodata((unsigned long)addr))
> if (is_vmalloc_addr(addr))
is_kernel_rodata() is inlined, but is_vmalloc_addr() isn't. So the
overhead can be a bit bigger.
More information about the WireGuard