macOS Catalina failing https

Barry Scott barry at
Sun Mar 1 09:55:35 CET 2020

> On 27 Feb 2020, at 16:46, Sean Baildon <sean at> wrote:
> Hey,
> Recently purchased and upgraded a new MBP to Catalina.
> Requests to https enabled sites over the VPN no longer work, even
> using my old configuration. Requests to insecure sites—ex.
>—work just fine.
> My iOS devices work as expected. I've tried using the iOS
> configurations on the laptop, but it's the same behaviour; hanging.
> I'm using the Mac App Store version of wireguard on a vanilla install
> of macOS Catalina. Are there any known issues? Happy to provide any
> useful debug

I just noticed that I tested with /opt/local/bin/curl not /usr/bin/curl.

Both worked. For completeness here is the start of the curl --verbose
that shows the certificate store that is used:

$ /usr/bin/curl --verbose
*   Trying
* Connected to ( port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/cert.pem
  CApath: none


> Thanks,
> Sean
> _______________________________________________
> WireGuard mailing list
> WireGuard at

More information about the WireGuard mailing list