Behaviour on MTU problem

M. Dietrich mdt at
Mon Aug 30 18:43:03 UTC 2021

Hi friends of Wireguard,

i am neither a network guru nor a kernel hacker and after all 
i had no time to fully investigate the case. so please read 
with a grain of salt.

i had my notebook in a wifi network lately that seemed to have 
some MTU size problems. download worked fine while uploads 
blocked for bigger packages. when i set the MTU down to 1200 
on the wg interface the same upload worked fine.

this was obviously a problem of that very wifi network and is
not related to wg at all, the dhcp answer did not even contain 
any MTU hints, so 1500 was assumed.

anyway the kernel locked up. commands like `ip` or `wg-quick 
down ...` get stuck and ^C oder even a `kill -9 ...` did not 
end the processes. any access to the wg interface blocked.

my question is if that scenario (misconfigured MTU size in the 
"outer network") is tested and works fine. i know that MTU 
size problem lead to lockups (that's why i immediatly came to 
that conclusion) but never saw such a hard lockup related to 
commands like `ip`.

if my assumption is just stupid let me know. if not i would 
further investigate the case, setup a test scenario and burn 
some time. what do you think?

best regards, michael

More information about the WireGuard mailing list