tunnel no longer established :: how to debug? - solved

Adrian Sevcenco adrian.sev at gmail.com
Wed Jun 2 07:23:12 UTC 2021

On 6/2/21 9:36 AM, Adrian Sevcenco wrote:
> Hi! After a change of connection point (the same ISP but different location, but with the same wireless, and end-points)
> the tunnel no longer is established. Nothing in the wg configuration is changed ...
> from the "client" machine to the "server" end-point i can do:
> root at hal: ~ # nc -u -vz sev.HHHHHH 43333
> Ncat: Version 7.80 ( https://nmap.org/ncat )
> Ncat: Connected to HHH.HHH.HHH.HHH:43333.
> Ncat: UDP packet sent successfully
> Ncat: 1 bytes sent, 0 bytes received in 2.01 seconds.
> How can i debug further to see why the connection is not established?
i apologize for the noise! the problem was a typo on the server configuration
where a peer was defined also with it's endpoint (dynamic) dns name.
this worked fine as long that name was resolving correctly but as soon as this
failed the connection could no longer be established.


More information about the WireGuard mailing list