Windows Client Can't Set MTU Below 1280

Clark Case clarkcase at
Sat Nov 5 00:30:25 UTC 2022

Hi All - I'm trying to set up a WireGuard tunnel via udp2raw. The
client side is running Windows, the server is the linuxserver docker

I can get the tunnel set up through udp2raw, I can ping across it, I
can use mosh across it, I can sometimes do ssh, but I can't get HTTP
either with a browser or with curl. Based on some input on reddit, I'm
trying to lower the MTU of the virtual adapter. However, the lower
limit that seems to be permitted by the client seems to be 1280 - and
1280 doesn't fix the problem. Below 1280, I get an error when trying
to activate the tunnel.

I'm assuming that this is because of some code in here:

var minMTU uint32
if family == windows.AF_INET {
minMTU = 576
} else if family == windows.AF_INET6 {
minMTU = 1280
I'm not trying to do anything via IPV6, and I don't have an IPV6
address specified on the server side or the client side config files.
I've tried disabling IPV6 in the physical adapter the virtual adapter
is binding to, but I still get the error.

So, is there something else I should be doing to convince WireGuard
that I just want to do IPV4?

More information about the WireGuard mailing list