Help moving pass to new computer

Sam Stone sam at
Wed Sep 25 20:28:04 CEST 2019

Hi All,

My old Gentoo box died. I'm trying to install pass on my new Gentoo box. I managed to copy my old home dir to a usb. I can see password-store directory and my gnupg directory. gpg --list keys shows the key I used to originally  encrypt my password. I have also installed the gnupg package.

I ran pass init passwords at The new .gpg-id 

contains one line with "passwords at". The original.gpg-id file on the usb contains the correct hex id of the key. I copied the contents orginal .password-store dir into the new one.   When I try to decrypt a password I get a "gpg:decryption failed: No secret key" error. I get this error regardless of which of the 2 entries are present in the .gpg-id file. Every time I've tried to decrypt there has been only .gpg-id entry. 

I have tried copying the orginal .gpg-id file to the new .password-store dir.

I have tried pass init passwords at 

I have tried pass init hex (in lower case) 

I have tried pass init  (in upper case) 

All the above result in a No secret key error.

I feel like I'm overlooking something obvious or making a rather simple mistake. 

I hope I'm not totally fucked. 

Any help would be very much appreciated.

Sam Stone

Sent with ProtonMail Secure Email.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 477 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the Password-Store mailing list