Problems in the macOS Terminal app with `pass show -c some/password`?

yanchenko.igor at yanchenko.igor at
Thu Dec 30 05:43:34 UTC 2021

I suggest to record your terminal using script:

script logfile.txt
pass show -c some/password

And then check the logfile.txt, which might give you some ideas.

On Thu, Dec 30, 2021 at 1:57 AM Kenny Evitt <kenny.evitt at> wrote:
> I installed `pass` via Homebrew – version `v1.7.4`.
> I'm setting-up a new Mac (macOS 12.0.1) and I've noticed a weird
> problem with the (macOS included) Terminal app whenever I use the
> `pass show -c ...` command.
> It _seems_ like maybe the 'clip' program that's being used doesn't
> work well with the (new?) version of the Terminal app – or something
> along those lines.
> After I run `show -c` commands (which works), the "Copied ... to
> clipboard" messages 'clobbers' the shell prompt and then further input
> doesn't _visibly_ work – I can type and maybe (?) run commands, but
> the command seems to be 'erased' after I run it (i.e. hit Enter) and
> no output is visible in the shell. I'd _guess_ somehow the same 'line'
> of the shell output/history is being repeatedly overwritten.
> Any ideas?

More information about the Password-Store mailing list