[WireGuard] LEDE / OpenWrt test - on TP-Link841Nv11 - 15MBs and crash

jens jens at viisauksena.de
Wed Aug 10 03:37:00 CEST 2016

On 04.08.2016 13:34, jens wrote:
> [ X  ] I have tried removing "sk_clear_memalloc(sock);" and
> "sk_set_memalloc(sock->sk);" from socket.c, and the problem still
> continued.
> [  ] I have tried removing "sock->sk->sk_sndbuf = INT_MAX;" from
> socket.c, and the problem still continued.

we just want to inform you that we want to run some more tests in the
next days, including your suggestions and compare all with fastd (which
we also test), and everything also on a different router - we write to
the list as soon we have some results on this.

Testsetup will stay the same: (see first post for details)
laptop (iperf3) > tp841v11 <- WireGuard -> tp841v11 < laptop (iperf3)

we will test
    default lede Wireguard(20160630),
    latest wireguard(20160808),
    latest wireguard without memalloc(step1) ,
    latest wireguard without sndbuf = INT_MAX (step2)

we will also compare the setup to a similar router : TPLink cpe210 ,
with 64MB ram and 8 mb flash with similar cpu (maybe not with all tests
so far)

the ready to use builded packages (Firmware and ipk) are already laying
here http://openfreiburg.de/freifunk/firmware/
if some want to play around with them.

if there are any suggestions and ideas we could/should add, we are happy
to hear from you
(its all about hunting the out of memory issue on heavy udp traffic
through wireguard tunnel)


make the world nicer, please use PGP encryption

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.zx2c4.com/pipermail/wireguard/attachments/20160810/c50c3ab7/attachment.html>

More information about the WireGuard mailing list