[WireGuard] WireGuard on OpenWRT: Success
Jason A. Donenfeld
Jason at zx2c4.com
Tue Nov 8 17:12:34 CET 2016
Not really knowing anything about OpenWRT configuration, this is what
I wound up with:
sed -i s/REJECT/DROP/g /etc/config/firewall
Then these sections are new or changed:
/etc/config/firewall:
config zone
option name wg
list network 'demobox'
option input DROP
option output ACCEPT
option forward DROP
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wg
/etc/config/network:
config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'
option defaultroute 0
option customroutes '163.172.161.0/32'
config interface 'demobox'
option proto 'wireguard'
option private_key '...'
option preshared_key '...'
option addresses '.../32'
config wireguard_demobox
option public_key '...'
option allowed_ips '0.0.0.0/0'
option route_allowed_ips 'enabled'
option endpoint_host '163.172.161.0'
option endpoint_port '...'
More information about the WireGuard
mailing list