[WireGuard] Hosting Companies with Dishonest CPUID [Was: Re: Seeking Ubuntu PPA Maintainer]

Egbert Verhage egbert at eggiecode.org
Wed Nov 16 15:44:29 CET 2016

Hey Jason,

The service/hardware is great. But it is a problem with the raid6 module 
on the host.
That uses AVX/AVX2. PCExtreme hasalready blacklisted AVX because all of 
the virtual machines crashes with it enabled.

I'm the only complaining about AVX2 crashing on the machines, so 
therefore it is not yet blacklisted.

Just sended a email to them, waiting on response. Wanted to add the 
mail, but it is in dutch. I don't know if you can read that.


On 2016-11-16 15:14, Jason A. Donenfeld wrote:
> Hey Egbert,
> I'm glad that my avx2disabler module worked for you. I believe it
> would be in your interest to pressure the hosting provider into either
> reenabling AVX, or fixing their CPUID to report correct information.
> CPUID is the kernel's only means of judging capabilities, and if the
> [virtual] hardware lies, it is impossible to make a reliable operating
> system.
> Jason
> On Wed, Nov 16, 2016 at 11:03 AM, Egbert Verhage <egbert at eggiecode.org> wrote:
>> Hey Jason,
>> The kernel module worked for my. ([1020751.674357] AVX2 disabler loaded:
>> 1 -> 0)
>> Going to update the PPA to remove my disable of AVX2.
>> The problem is that the hosting company hides the cpuuid, but from the
>> call with the sysadmin it is a XEON E5-2??? v3.
>> Greetz,
>> Egbert
>> On 2016-11-16 02:31, Jason A. Donenfeld wrote:
>>> Hey Egbert,
>>> On Wed, Nov 16, 2016 at 1:34 AM, Egbert Verhage <egbert at eggiecode.org> wrote:
>>>> I mailed/called with one of the sys admins and discussed with him about the
>>>> problem in the AVX2 extention.
>>>> I think I'm going to mail/call the hosting company again.
>>> It seems like the crux of the issue is that if they disable AVX2
>>> instructions, they need to make this known in the CPUID. Otherwise the
>>> operating system will assume it's there when it isn't.
>>>> Can give you a vps if you want to. Just 3 euro the month.
>>> See the attached tarball. Compile the kernel module in there and load
>>> it BEFORE WireGuard. You might have to manually unload wireguard for
>>> this to work: "rmmod wireguard && insmod ./avx2disabler.ko && modprobe
>>> wireguard", for example. It should disable avx2 inside the kernel,
>>> solving the issue.
>>> Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.zx2c4.com/pipermail/wireguard/attachments/20161116/a97e2f9f/attachment-0001.html>

More information about the WireGuard mailing list