Latest Gentoo WireGuard Ebuilds Doesn't Work

Konstantin konstantin at
Wed Aug 9 00:22:44 CEST 2017

On 2017-08-07 17:17, Konstantin wrote:
> Hi guys,
> I have issues upgrading WireGuard on my Gentoo servers. I tried
> different kernels and latest WireGuard versions without any luck.
> When I type wg command I got only the "interface" portion:
> interface: wg0
>   public key: PUkm5fRn25hbv9Zh2tetny3tV3l9WnbxvIFeZTSd9BM=
>   private key: (hidden)
>   listening port: 58800
> without any peer block below.
> Latest WireGuard version that still works for me was 0.0.20170214 but
> I can't find these sources anymore and I need to upgrade to a new
> kernel.
> According to kernel requirements (here
>  ) I understand that need to have a certain options enables.
> My current kernel 4.9.34 config has:
> Yes, some of these modules are not built-in but I had it the same way
> earlier when it worked with kernel 4.4.39.
> When I'm loading the wireguard.ko module and setting wg interface
> configuration I don't see any error but not even a single packet
> leaves a server interface towards the peer. What am I missing here?
> How can I debug it?
> Thank you.

For the record I want to explain what was the problem and how it was 
solved. I haven't noticed that in the old configuration file the same 
pair of keys were used for both sides. And new WG version doesn't allow 
to use it that way. Obviously it was a wrong configuration which 
apparently works using an old WG version. That's it. Thank you!


More information about the WireGuard mailing list