Interface's Address is not saved when SaveConfig = true in config

ST smntov at
Fri Apr 20 12:36:29 CEST 2018


I have 
Address =
SaveConfig = true
in wg0.conf

1. if I add a peer with `wg set wg0 peer ...` WG doesn't add it
immediately to the wg0.conf file, only after I run `wg-quick down wg0`.
Why not? What happens if the system crashes unexpectedly?... The peer
will not be saved to the config file and the information will be lost.

2. once I run `wg-quick down wg0` I get:

Option "-all" is unknown, try "ip -help".
cat: /etc/resolvconf/run/interface/wg0: No such file or directory
[#] wg showconf wg0
sync: ignoring all arguments
[#] ip link delete dev wg0

Now the wg0.conf is enhanced with the peer details that was added
through command line, but the Address = disappears from
the config. So running `wg-quick up wg0` again doesn't assigns IP to the
wg0 interface... What's wrong?

I'm using version:
apt list wireguard
wireguard/unstable,now 0.0.20180304-1 all [installed]

Thank you!

More information about the WireGuard mailing list