Potential bug in Android app - Create from scratch flow

Dana White danabw at hotmail.com
Mon Apr 6 00:55:01 CEST 2020

Thanks. Using the config was just to test the import process on Android w/a known good config, deleted thereafter. 
From your reply sounds like you haven't seen this issue w/the current version of the app? Are you able to manually create and use a new tunnel on the Android app successfully? 

I had another member of the EdgeRouter community note that he had what he thought was a similar problem recently w/the Android app but didn't take the time to follow upon it. 

I'll do as you request and get back. 


-----Original Message-----
From: Jason A. Donenfeld <Jason at zx2c4.com> 
Sent: Sunday, April 5, 2020 2:54 PM
To: Dana White <danabw at hotmail.com>
Cc: WireGuard mailing list <wireguard at lists.zx2c4.com>
Subject: Re: Potential bug in Android app - Create from scratch flow

> Finally (thanks to someone on #wireguard irc) I tried imported the exact same config into the app, and it worked immediately.

Don't use the same config from two devices. One device :: one private key.

> It looks like there may be a problem w/the manual entry process. At least that was my experience, repeatedly. App is current version, just installed for the first time two days ago.

Create it manually, and then export it to a zip. Look in the zip and see if there's any difference between that file and the one you imported from the windows app.

More information about the WireGuard mailing list