Potential bug in Android app - Create from scratch flow

Dana White danabw at hotmail.com
Mon Apr 6 01:23:20 CEST 2020

OK, operator error once again is to blame. 

My router public key in the config had a single digit missing. 

The really odd part is that I can't understand how that happened, as I copy/pasted the router public key from an existing config (that still works and has the full correct key) because there was no way I was going to type out something that long/difficult. I do have problems with my mousepad on my computer sometimes jumping the cursor around when my palm hits it and sometimes messing up what I’m doing, but no idea how that could account for removing a letter and not leaving a space. 

But egg on my face is egg on my face, what can I say. 

Bowing and backing away in shame. 

Thanks for the suggestion to export/compare, that was what allowed me to see the issue clearly. 


-----Original Message-----
From: Jason A. Donenfeld <Jason at zx2c4.com> 
Sent: Sunday, April 5, 2020 2:54 PM
To: Dana White <danabw at hotmail.com>
Cc: WireGuard mailing list <wireguard at lists.zx2c4.com>
Subject: Re: Potential bug in Android app - Create from scratch flow

> Finally (thanks to someone on #wireguard irc) I tried imported the exact same config into the app, and it worked immediately.

Don't use the same config from two devices. One device :: one private key.

> It looks like there may be a problem w/the manual entry process. At least that was my experience, repeatedly. App is current version, just installed for the first time two days ago.

Create it manually, and then export it to a zip. Look in the zip and see if there's any difference between that file and the one you imported from the windows app.

More information about the WireGuard mailing list