Windows stuck in boot after WireGuard update (switch to WireGuardNT?)

Oliver Freyermuth freyermuth at
Wed Sep 22 10:09:06 UTC 2021

Dear Jason,

we have observed two cases (laptops, one running Windows 10 Enterprise, the other Windows 10 Pro 2009)
in which Windows got stuck during boot (during the "rotating dots", which keep rotating forever).

This has been observed end of last week for one laptop, and just today for the other affected laptop.
Both systems have installed WireGuard updates "as they were released", i.e. both were running 0.4.9 when the error occured.
Both laptops use BitLocker disk encryption (but I suppose this is not part of the issue).
While both machines are shut down and started up daily, both may not have seen a full reboot until the error occured (thanks to Windows fast startup).

I could revive the systems and pinpoint the issue down to WireGuard as follows:
- Start in "safe mode".
   Note that "safe mode with network drivers" will also get stuck.
- Login with an admin account, and in Device manager, disable or uninstall the following two network adapters:
     WireGuard Tunnel
     Microsoft Kernel Debug Network Adapter (is this also pulled in via WireGuard?)

After that, the laptops reboot fine again, and strangely enough, WireGuard is usable right away (using the WireGuard NT driver).
I tried to provoke the issue when the laptops were in my hand, by enabling / disabling WireGuard, rebooting, shutting down and starting up,
installing all Windows updates which were available, but to no avail.

However, once I returned the first laptop back to the user, it has shown the same issue again ~24 hours later (still running WireGuard 0.4.9).
Of course, since these are laptops, they see many connection state changes, in case this may be a trigger of the issue.

To further pinpoint the issue, I have used:
  reg add HKLM\Software\WireGuard /v UseUserspaceImplementation /t REG_DWORD /d 1 /f
on one of the two laptops, to check if this prevents reappearance of the issue (I ran that only now, so no feedback by the user yet).

Since both are in heavy use by the respective users, I can sadly not keep them for long to do more detailed debugging,
and I have not yet managed to reproduce such an issue with any of our test machines (which are however not laptops).
I've also net yet managed to trigger this on my own Windows 10 laptop, so this may be some kind of very evasive / rare issue.

Does this kind of issue ring any bells?


PS: I am not (yet) subscribed to the list, so pleace CC me in replies. Thanks!

Oliver Freyermuth
Universität Bonn
Physikalisches Institut, Raum 1.047
Nußallee 12
53115 Bonn
Tel.: +49 228 73 2367
Fax:  +49 228 73 7869

More information about the WireGuard mailing list