WireGuard Configurations Gone After iOS 15 Upgrade

Andrew Fried afried at spamteq.com
Wed Sep 22 14:47:07 UTC 2021

I ran into the same problem on my iPhone  and 4 separate iPads.

The solution: delete the wireguard app, then re-download it from the app 
store.  Problem solved.


On 9/22/21 1:17 AM, Jason A. Donenfeld wrote:
> On Tue, Sep 21, 2021 at 10:50 PM Jason A. Donenfeld <Jason at zx2c4.com> wrote:
>> 2. When the app can't open a keychain item, it deletes the VPN
>> profile? Or does it just gray it out? If it's deleting it, that's
>> wrong; it ought to just remain disabled until it's readable again.
> This is now fixed with https://w-g.pw/l/dteZ
>> 1. Something goes wrong with the keychain from 14->15 and the app
>> loses authorization.
> This I still have no idea about, as I can't reproduce the issue. It
> would be useful to know if it's transient, and so the fix to (2) above
> basically handles the issue by not blowing away the VPN profile. If
> somebody's got a reliable reproduction rig and can build this in
> xcode, I'd be interested in feedback here on what's in the master
> branch.
> Jason

Andrew Fried
afried at spamteq.com
+1.703.667.4050 Office
+1.703.362.0067 Mobile

More information about the WireGuard mailing list