[pass] Help re output of command pass & where is bash completion script

Geoff & Lynne Maclean joffa at glsr.org
Thu Mar 31 15:41:58 CEST 2016

On Thu, Mar 31, 2016 at 6:42 AM, Lucas Hoffmann <l-m-h at web.de> wrote:

> Quoting Geoff & Lynne Maclean (2016-03-28 11:17:20)
> > After a quick learning curve with pgp and git, I've set up pass and even
> > playing with qtpass so I can run it on a usb stick for work.
> > I've hit a small hiccup in that when I run the command pass, instead of
> > getting the 544 odd entries I have in a folder called All, I only get the
> > following:
> >
> >   $ pass ls
> >   (none)
> >   ---
> >   username: openphoto
> >   password: (none)
> >   url: [1]http://gwmaclean.openphoto.me/
> >   "
> >
> > I can't see that entry in qtpass, or in my .password-store folder (using
> > Arch Linux with gnome 3 with show hidden files enabled)
> > If I run pass All I can see my other entries i.e.:
> >
> >   $ pass All
> >   All
> >   ├──
> >   ├──
> >   etc
> >
> > I tried variations of pass rm none, (none) or '(none)' but it tells me
> > that none or (none) is not in the password store, or bash: syntax error
> > near unexpected token `('
> > My 1st question is:
> > How would I get ride of that (none) entry so all items show when I run
> > just plan old pass?
> Can you post the output of `find ~/.password-store -ls` and maybe `bash
> -x $(which pass) ls`?  Make sure that it does not contain sensitive
> information.

Read this after much fiddling with git etc and somehow I got rid of the
annoying openphoto entry and now all appears as it should.  I think as I
imported from Lastpass it was an odd entry from that.  I deleted my
original password.store folder, manually edited all exported entries from
Lastpass in a spreadsheet, reimported that into Keepass2 to import back to
Lastpass and then exported again to import into pass - all good now.  I
took that long import/export track as for whatever reason, only the
lastpass importer worked for me - none of the passwordsafe, or keepass
versions would work.

> > And, recently thru [2]reddit I saw the following for when importing from
> > Lastpass (which I did although I am using Passwordsafe (pwsafe) and that
> > importer didn't work at all for me):
> >
> >   For those who imported lastpass data, check and see if you have any
> data
> >   that wasn't under any catagory. If you do it will be under a folder in
> >   .password-store called (none). Use the command 'pass mv "(none)" Misc'.
> >   Name it anything to save yourselves any problems later. That way
> >   everything works perfectly. I'm shocked that I had never heard about
> >   this until now. Time to delete my acct on Lastpass
> >
> > That's what I did for my files, moving them to All.  Would that have
> > caused my problem above?
> > A suggestion I have is therefore that it would also be handy if that
> > reddit tip and any other tips, examples etc could be added to the web or
> > man page.
> The man page is for pass and therefore this link would be wrong there.
> Not sure about the web page.  Maybe in the migration section.
> > The web page states 'There is [3]bash [4]completion so that you can
> simply
> > hit tab to fill in names and commands' and the start of the man page
> > advises There is a corresponding bash completion script for use with tab
> > completing password names in bash(1).
> > My 2nd question is:
> > How do I actually find and use that script?
> It's in the source tar ball or the git repository under src/completion:
> https://git.zx2c4.com/password-store/tree/src/completion

I found the bash-completion script (now I know how it is referenced on the
website, it seems perfectly clear now where the script is, plus Arch
packages it, but it took ages to work that out), however just posted a
question about how to actually make the script work - sorry.

​Thanks Lucus​
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.zx2c4.com/pipermail/password-store/attachments/20160401/8d26d8ac/attachment.html>

More information about the Password-Store mailing list