[PhotoFloat] How to deal with problems?

martin f krafft madduck at madduck.net
Sun Jan 18 23:29:40 CET 2015

also sprach Martin Dimitrov <martian at mafiainc.net> [2015-01-18 21:37 +0100]:
> Your PhotoFloat is broken, because you don't seems to have js/ and css/
> directories available under /pf. For example:
> http://alan.madduck.net/~madduck/pf/js/scripts.min.js should be
> available and should not return 404 error. You should just check your
> links and/or rights.

Thank you for your reply!

The access rights all seem ok:

  alan:~/public_html/pf% ls -ld /home/madduck/public_html/pf/js /home/madduck /home/madduck/PhotoFloat /home/madduck/PhotoFloat/web /home/madduck/PhotoFloat/web/js /home/madduck/PhotoFloat/web/js/*
  lrwxrwxrwx  1 madduck madduck     31 Jan 18 21:43 /home/madduck/public_html/pf/js -> /home/madduck/PhotoFloat/web/js
  drwx--x--x 27 madduck madduck   4096 Jan 18 20:23 /home/madduck
  drwxr-xr-x  5 madduck madduck   4096 Jan 18 20:38 /home/madduck/PhotoFloat
  drwxr-xr-x  7 madduck madduck   4096 Jan 18 21:46 /home/madduck/PhotoFloat/web
  drwxr-xr-x  2 madduck madduck   4096 Jan 18 20:34 /home/madduck/PhotoFloat/web/js
  -rw-r--r--  1 madduck madduck 268381 Jan 18 20:22 /home/madduck/PhotoFloat/web/js/000-jquery-1.9.1.js
  -rw-r--r--  1 madduck madduck  16465 Jan 18 20:22 /home/madduck/PhotoFloat/web/js/001-hashchange.js
  -rw-r--r--  1 madduck madduck    263 Jan 18 20:22 /home/madduck/PhotoFloat/web/js/002-preloadimages.js
  -rw-r--r--  1 madduck madduck   2235 Jan 18 20:22 /home/madduck/PhotoFloat/web/js/003-mousewheel.js
  -rw-r--r--  1 madduck madduck   3176 Jan 18 20:22 /home/madduck/PhotoFloat/web/js/004-fullscreen.js
  -rw-r--r--  1 madduck madduck   5400 Jan 18 20:22 /home/madduck/PhotoFloat/web/js/010-libphotofloat.js
  -rw-r--r--  1 madduck madduck  13641 Jan 18 20:22 /home/madduck/PhotoFloat/web/js/011-display.js

So unless this is some whackiness related to lighttpd (I am new to
lighttpd, trying it out for the first time after 17 years of
Apache), I am at a loss here.

However, this is not the issue (see below, it works now).
Nevertheless, http://alan.madduck.net/~madduck/pf/js/ still gives
a 404, but this is probably because lighttpd cannot find index.html
and is not configured to generate a directory listing.

> Also make sure that ~/photos is accessible from WWW otherwise you
> would end up with haveing only thubnails and small images, but
> when you want to see the full size image wouldn't be available.

Noted. This is actually what I want.

> In case you don't have *.min.js files under js/ and *.min.css under css/
> then you should go one level down where the Makefile is located and run
> make to create these files. Just pay attention on the documentation here
> for all the details: http://git.zx2c4.com/PhotoFloat/about/

Aha! From reading this page, I had been under the impression that
this was an optional step (minimising the JS/CSS) and so I skipped

So now I compiled them on another system and copied them over and
now it works. Thank you so much!

@martinkrafft | http://madduck.net/ | http://two.sentenc.es/
"without a god, life is only a matter of opinion."
                                                    -- douglas adams
spamtraps: madduck.bogus at madduck.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: digital_signature_gpg.asc
Type: application/pgp-signature
Size: 1107 bytes
Desc: Digital signature (see http://martin-krafft.net/gpg/sig-policy/999bbcc4/current)
URL: <http://lists.zx2c4.com/pipermail/photofloat/attachments/20150118/e799d3ea/attachment.asc>

More information about the PhotoFloat mailing list