trouble installing on Fedora and CentOS

adam souzis adam at
Tue Aug 8 21:58:58 CEST 2017

I've been impressed with Wireguard, its design has helped simplify the
implementation of a distributed sandbox app I am building quite a bit. But
I have had mixed results getting it running on different distributions.

The good news is that I can report that I was able to build, install and
run Wireguard on CoreOs.

The bad news is I was unable to get Wireguard working on either CentOS 7,
Fedora 26 or Fedora 25 (running these on AWS), it doesn't appear to be
installing the kernel module properly.

Here's what I see when install the RPM:

+ dkms add -m wireguard -v 0.0.20170629 -q --rpm_safe_upgrade

+ dkms build -m wireguard -v 0.0.20170629 -q

+ dkms install -m wireguard -v 0.0.20170629 -q

D: %post(wireguard-dkms-1:0.0.20170629-2.fc25.noarch): waitpid(14760) rc
14760 status 100

warning: %post(wireguard-dkms-1:0.0.20170629-2.fc25.noarch) scriptlet
failed, exit status 1

Non-fatal POSTIN scriptlet failure in rpm package wireguard-dkms

Looks like it might have worked:

[fedora at ip-1~]$ sudo dkms status

wireguard, 0.0.20170629: added


[fedora at ip-1 ~]$ sudo ip link add dev wg0 type wireguard

RTNETLINK answers: Operation not supported
I tried this on the latest version of the RPM and this earlier version. I
also tried compiling it from source on Fedora but make failed early on.

I disabled selinux, verified the kernel config is good and manually enabled
udp_tunnel for good measure. Any other suggestions? (I did see an earlier
post here recommending using kernel-ml for centos 7 but I need to use the
Atomic Host variant and swapping out the kernel on that is non-trivial. I
was hoping using a recent Fedora would solve the kernel compatibility

thank you!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the WireGuard mailing list