MacOS and wg 1.0.11 issues (for me)

Janne Johansson at
Fri Dec 18 16:59:51 CET 2020

I waited until 1.0.11 was out to not have to workaround the 1.0.10
issue if you didn't have DNS in the [Interface] section, and got a
"reverse" of it. I could not connect tunnels which did have DNS
entries in the interface section. As soon as I tried removing DNS =
the tunnels worked fine.

After MUCH back and forth with Jason, I have ended up where I can
either have DNS set in resolv.conf only and not ask wg to set any, OR,
I can have a local resolver running on, and ask wg via the
tunnel interface config to set this one and it will work for me. If my
localhost resolver is not running, the tunnel also doesn't come up.

I have no idea why my Mac is this weird, and we have tried a lot in
order to replicate this at his end without luck, so if anyone out
there upgrades to .11, has issues as long as DNS= is in the interface
section, please reach out to jason (and/or me) so we can figure why
this happens and what the conditions to trigger/reproduce this is.

In my case, the gui quickly shows the local udp port, then it goes
away. Data sent show some 146 bytes, but it doesn't show any received
data or a timestamp for last handshake.

wg logs have lines looping like this when it doesn't work:
2020-12-18 16:32:35.876 [NET] peer(kU2O…g42s) - Sending handshake initiation
2020-12-18 16:32:35.877 [NET] peer(kU2O…g42s) - Failed to send
handshake initiation no bind
2020-12-18 16:32:41.042 [NET] peer(kU2O…g42s) - Handshake did not
complete after 5 seconds, retrying (try 2)

Macbook pro, Big Sur 11.1, wg 1.0.11(20) from app store, and configs
that used to run ok in the 2019 wg from app store.

May the most significant bit of your life be positive.

More information about the WireGuard mailing list